欢迎光临
我们一直在努力

composer错误: Composer\Downloader\TransportException

 [Composer\Downloader\TransportException]
  The "http://packagist.org/packages.json" file could not be downloaded: failed to open stream: HTTP request failed!

create-project [-s|--stability="..."] [--prefer-source] [--prefer-dist] [--repository-url="..."] [--dev] [--no-dev] [--n
o-plugins] [--no-custom-installers] [--no-scripts] [--no-progress] [--keep-vcs] [--no-install] [--ignore-platform-reqs]
[package] [directory] [version]

解决方法禁用https请求,改用http方式。所以我们在composer.json文件中设置一个本地或全局的composer配置config

方法一:命令行composer config secure-http false。通过命令修改composer.json,效果等同方法二。

方法二:直接改composer.json,给“config”项中加上”secure-http”: false

"config" : {  
        "vendor-dir" : "packages",
        "secure-http": false  
}

 

全局配置(推荐)

composer config -l -g
//切换到国内源  阿里
composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
composer config -g --unset repos.packagist

未经允许不得转载:mbku » composer错误: Composer\Downloader\TransportException

分享到:更多 ()

相关推荐

  • 暂无文章

翰林黄金-重庆运营中心

翰林黄金翰林金业